Paxum Is Not Vulnerable To Heartbleed


April 10th, 2014

We are happy to confirm that Paxum is not vulnerable to the Heartbleed security bug featured prominently in this weeks news.

Many popular and large sites have been affected by Heartbleed, as well as some of our competitors sites, and we want to assure our clients that Paxum is not vulnerable.

We urge you to visit the Heartbleed site to learn more about this security bug, and evaluate which of the regular sites you visit may be vulnerable. To learn more about Heartbleed and the sites affected by this security bug, please visit
Paxum continues to provide a secure online platform that enables instant global P2P payments worldwide. If you have any questions about our security, please don’t hesitate to contact us.
Best regards,
The Paxum Team